summaryrefslogtreecommitdiffstats
path: root/src/intel/vulkan/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/intel/vulkan/Makefile.am')
-rw-r--r--src/intel/vulkan/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/intel/vulkan/Makefile.am b/src/intel/vulkan/Makefile.am
index c7e3ebcaade..983b4c2af28 100644
--- a/src/intel/vulkan/Makefile.am
+++ b/src/intel/vulkan/Makefile.am
@@ -176,7 +176,12 @@ libvulkan_intel_la_LIBADD = $(WAYLAND_LIBS) \
$(PER_GEN_LIBS)
libvulkan_intel_la_LDFLAGS = \
- -module -avoid-version -shared -shrext .so
+ -shared \
+ -module \
+ -no-undefined \
+ -avoid-version \
+ $(GC_SECTIONS) \
+ $(LD_NO_UNDEFINED)
# Generate icd files. It would be nice to just be able to add these to