aboutsummaryrefslogtreecommitdiffstats
path: root/src/intel/isl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/intel/isl/Makefile.am')
-rw-r--r--src/intel/isl/Makefile.am13
1 files changed, 4 insertions, 9 deletions
diff --git a/src/intel/isl/Makefile.am b/src/intel/isl/Makefile.am
index 51e2ae1733f..57313baa4f2 100644
--- a/src/intel/isl/Makefile.am
+++ b/src/intel/isl/Makefile.am
@@ -100,20 +100,15 @@ isl_format_layout.c: isl_format_layout_gen.bash \
# Tests
# ----------------------------------------------------------------------------
-TESTS = tests/isl_surf_get_image_offset_test
+check_PROGRAMS = tests/isl_surf_get_image_offset_test
-check_PROGRAMS = $(TESTS)
+TESTS = $(check_PROGRAMS)
-# Link tests to lib965_compiler.la for brw_get_device_info().
-tests_ldadd = \
- libisl.la \
+tests_isl_surf_get_image_offset_test_LDADD = \
+ libisl.la \
$(top_builddir)/src/mesa/drivers/dri/i965/libi965_compiler.la \
-lm
-tests_isl_surf_get_image_offset_test_SOURCES = \
- tests/isl_surf_get_image_offset_test.c
-tests_isl_surf_get_image_offset_test_LDADD = $(tests_ldadd)
-
# ----------------------------------------------------------------------------
EXTRA_DIST = \