aboutsummaryrefslogtreecommitdiffstats
path: root/src/intel/common/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/intel/common/meson.build')
-rw-r--r--src/intel/common/meson.build30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/intel/common/meson.build b/src/intel/common/meson.build
index 540d78f90b5..61fd35d5ef8 100644
--- a/src/intel/common/meson.build
+++ b/src/intel/common/meson.build
@@ -64,3 +64,33 @@ if install_intel_gpu_tests
)
endforeach
endif
+
+if with_tests
+ gentest_xml = files('tests/gentest.xml')
+ _name = 'gentest_pack.h'
+ gentest_pack = custom_target(
+ _name,
+ input : [gen_pack_header_py, gentest_xml],
+ output : _name,
+ command : [prog_python, '@INPUT@'],
+ capture : true,
+ )
+
+ genxml_path = join_paths(meson.source_root(),
+ '@0@'.format(gentest_xml[0]))
+
+ test(
+ 'genxml_test',
+ executable(
+ 'genxml_test',
+ ['tests/genxml_test.c', gentest_pack],
+ include_directories : [inc_common, inc_intel],
+ link_with : [libintel_common, libmesa_util],
+ c_args : [
+ '-DGENXML_PATH="@0@"'.format(genxml_path)
+ ],
+ ),
+ args : ['-quiet'],
+ suite : ['intel'],
+ )
+endif