aboutsummaryrefslogtreecommitdiffstats
path: root/src/glx/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/glx/tests/Makefile.am')
-rw-r--r--src/glx/tests/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/glx/tests/Makefile.am b/src/glx/tests/Makefile.am
new file mode 100644
index 00000000000..e7e2697cb9d
--- /dev/null
+++ b/src/glx/tests/Makefile.am
@@ -0,0 +1,22 @@
+AM_CPPFLAGS = \
+ -I$(top_builddir)/src/gtest/include \
+ -I$(top_builddir)/src/mapi \
+ -I$(top_builddir)/src/glx \
+ -I$(top_builddir)/include \
+ $(X11_CFLAGS)
+
+if HAVE_XCB_GLX_CREATE_CONTEXT
+TESTS = glx_unittest
+check_PROGRAMS = glx_unittest
+
+glx_unittest_SOURCES = \
+ clientinfo_unittest.cpp \
+ create_context_unittest.cpp \
+ fake_glx_screen.cpp
+
+glx_unittest_LDADD = \
+ $(top_builddir)/src/glx/libglx.la \
+ $(top_builddir)/src/gtest/libgtest.la \
+ -lpthread
+
+endif