summaryrefslogtreecommitdiffstats
path: root/src/glx/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/glx/tests/Makefile.am')
-rw-r--r--src/glx/tests/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/glx/tests/Makefile.am b/src/glx/tests/Makefile.am
index ad18f85fe01..a7a23faf32e 100644
--- a/src/glx/tests/Makefile.am
+++ b/src/glx/tests/Makefile.am
@@ -1,6 +1,8 @@
+if HAVE_SHARED_GLAPI
AM_CPPFLAGS = \
-I$(top_builddir)/src/gtest/include \
-I$(top_builddir)/src/mapi \
+ -I$(top_builddir)/src/mesa \
-I$(top_builddir)/src/glx \
-I$(top_builddir)/include \
$(X11_CFLAGS)
@@ -18,4 +20,6 @@ glx_test_SOURCES = \
glx_test_LDADD = \
$(top_builddir)/src/glx/libglx.la \
$(top_builddir)/src/gtest/libgtest.la \
+ $(top_builddir)/src/mapi/shared-glapi/libglapi.la \
-lpthread
+endif