summaryrefslogtreecommitdiffstats
path: root/src/glx/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/glx/meson.build')
-rw-r--r--src/glx/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/glx/meson.build b/src/glx/meson.build
index 82141d3d4e5..7ac46ac0662 100644
--- a/src/glx/meson.build
+++ b/src/glx/meson.build
@@ -18,6 +18,9 @@
# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
# SOFTWARE.
+inc_glx = include_directories('.')
+
+subdir('apple')
if with_dri_platform == 'windows'
subdir('windows')
endif
@@ -100,6 +103,7 @@ endif
if with_dri_platform == 'apple'
files_libglx += files('applegl_glx.c')
+ extra_libs_libglx += libappleglx
elif with_dri_platform == 'windows'
files_libglx += files('driwindows_glx.c')
extra_libs_libglx += [