summaryrefslogtreecommitdiffstats
path: root/src/glx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/glx/Makefile.am')
-rw-r--r--src/glx/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/glx/Makefile.am b/src/glx/Makefile.am
index eb202403b67..0c99c0709d6 100644
--- a/src/glx/Makefile.am
+++ b/src/glx/Makefile.am
@@ -109,8 +109,10 @@ GL_LIBS = \
$(GL_LIB_DEPS)
GL_LDFLAGS = \
+ -no-undefined \
+ -version-number 1:2 \
-Wl,-Bsymbolic \
- -version-number 1:2 -no-undefined
+ -Wl,--no-undefined
lib@GL_LIB@_la_SOURCES =
lib@GL_LIB@_la_LIBADD = $(GL_LIBS)