summaryrefslogtreecommitdiffstats
path: root/src/glsl/glcpp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/glsl/glcpp/Makefile.am')
-rw-r--r--src/glsl/glcpp/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/glsl/glcpp/Makefile.am b/src/glsl/glcpp/Makefile.am
new file mode 100644
index 00000000000..198908c6f2a
--- /dev/null
+++ b/src/glsl/glcpp/Makefile.am
@@ -0,0 +1,44 @@
+
+
+# Copyright © 2012 Matt Turner <[email protected]>
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+# IN THE SOFTWARE.
+
+noinst_LTLIBRARIES = libglcpp.la
+check_PROGRAMS = glcpp
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/mesa \
+ -I$(top_srcdir)/src/mapi \
+ -I$(top_srcdir)/include
+
+BUILT_SOURCES = glcpp-parse.h
+AM_YFLAGS = -d
+AM_LFLAGS = --nounistd -o$(LEX_OUTPUT_ROOT).c
+
+libglcpp_la_SOURCES = \
+ glcpp-lex.l \
+ glcpp-parse.y \
+ pp.c \
+ ../../mesa/program/hash_table.c \
+ ../ralloc.c
+
+glcpp_SOURCES = glcpp.c
+glcpp_LDADD = libglcpp.la