summaryrefslogtreecommitdiffstats
path: root/src/gallium/winsys/radeon/drm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/winsys/radeon/drm/Makefile.am')
-rw-r--r--src/gallium/winsys/radeon/drm/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/gallium/winsys/radeon/drm/Makefile.am b/src/gallium/winsys/radeon/drm/Makefile.am
new file mode 100644
index 00000000000..5b2506b35eb
--- /dev/null
+++ b/src/gallium/winsys/radeon/drm/Makefile.am
@@ -0,0 +1,15 @@
+include Makefile.sources
+include $(top_srcdir)/src/gallium/Automake.inc
+
+AM_CFLAGS = \
+ -I$(top_srcdir)/include \
+ $(GALLIUM_CFLAGS) \
+ $(RADEON_CFLAGS)
+
+noinst_LTLIBRARIES = libradeonwinsys.la
+
+libradeonwinsys_la_SOURCES = $(C_SOURCES)
+
+#XXX: Delete this when all targets using the radeon winsys are converted to automake.
+all-local: libradeonwinsys.la
+ ln -f $(builddir)/.libs/libradeonwinsys.a $(builddir)/libradeonwinsys.a