summaryrefslogtreecommitdiffstats
path: root/src/gallium/tests/trivial/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/tests/trivial/Makefile.am')
-rw-r--r--src/gallium/tests/trivial/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/gallium/tests/trivial/Makefile.am b/src/gallium/tests/trivial/Makefile.am
index 656ee64e0f5..15a81b3a696 100644
--- a/src/gallium/tests/trivial/Makefile.am
+++ b/src/gallium/tests/trivial/Makefile.am
@@ -20,6 +20,13 @@ LDADD = $(GALLIUM_PIPE_LOADER_CLIENT_LIBS) \
$(PTHREAD_LIBS) \
-lm
+if NEED_PIPE_LOADER_XLIB
+LDADD += \
+ $(top_builddir)/src/gallium/winsys/sw/xlib/libws_xlib.la \
+ -lX11 -lXext -lXfixes \
+ $(LIBDRM_LIBS)
+endif
+
noinst_PROGRAMS = compute tri quad-tex
compute_SOURCES = compute.c