summaryrefslogtreecommitdiffstats
path: root/src/gallium/tests/trivial/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/tests/trivial/Makefile.am')
-rw-r--r--src/gallium/tests/trivial/Makefile.am17
1 files changed, 3 insertions, 14 deletions
diff --git a/src/gallium/tests/trivial/Makefile.am b/src/gallium/tests/trivial/Makefile.am
index 8a8fad138e3..183fe8ed8b1 100644
--- a/src/gallium/tests/trivial/Makefile.am
+++ b/src/gallium/tests/trivial/Makefile.am
@@ -11,24 +11,13 @@ AM_CPPFLAGS = \
-DPIPE_SEARCH_DIR=\"$(PIPE_SRC_DIR)/.libs\" \
$(GALLIUM_PIPE_LOADER_DEFINES)
-LDADD = $(GALLIUM_PIPE_LOADER_CLIENT_LIBS) \
+LDADD = \
+ $(GALLIUM_PIPE_LOADER_CLIENT_LIBS) \
+ $(GALLIUM_PIPE_LOADER_WINSYS_LIBS) \
$(top_builddir)/src/gallium/auxiliary/pipe-loader/libpipe_loader_client.la \
- $(top_builddir)/src/gallium/winsys/sw/null/libws_null.la \
$(top_builddir)/src/gallium/auxiliary/libgallium.la \
$(GALLIUM_COMMON_LIB_DEPS)
-if HAVE_DRISW
-LDADD += \
- $(top_builddir)/src/gallium/winsys/sw/dri/libswdri.la
-endif
-
-if NEED_WINSYS_XLIB
-LDADD += \
- $(top_builddir)/src/gallium/winsys/sw/xlib/libws_xlib.la \
- -lX11 -lXext -lXfixes \
- $(LIBDRM_LIBS)
-endif
-
noinst_PROGRAMS = compute tri quad-tex
compute_SOURCES = compute.c