summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/xvmc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/xvmc/Makefile.am')
-rw-r--r--src/gallium/targets/xvmc/Makefile.am13
1 files changed, 3 insertions, 10 deletions
diff --git a/src/gallium/targets/xvmc/Makefile.am b/src/gallium/targets/xvmc/Makefile.am
index 041d920ed3e..812e597a277 100644
--- a/src/gallium/targets/xvmc/Makefile.am
+++ b/src/gallium/targets/xvmc/Makefile.am
@@ -43,21 +43,14 @@ TARGET_LIB_DEPS =
include $(top_srcdir)/src/gallium/drivers/nouveau/Automake.inc
-if HAVE_GALLIUM_R600
-MEGADRIVERS += r600
-STATIC_TARGET_CPPFLAGS += -DGALLIUM_R600
-STATIC_TARGET_LIB_DEPS += \
- $(top_builddir)/src/gallium/winsys/radeon/drm/libradeonwinsys.la \
- $(top_builddir)/src/gallium/drivers/radeon/libradeon.la \
- $(top_builddir)/src/gallium/drivers/r600/libr600.la \
- $(RADEON_LIBS)
-endif
+include $(top_srcdir)/src/gallium/drivers/r600/Automake.inc
if HAVE_GALLIUM_STATIC_TARGETS
libXvMCgallium_la_SOURCES += target.c
libXvMCgallium_la_CPPFLAGS = $(STATIC_TARGET_CPPFLAGS) $(TARGET_CPPFLAGS)
-libXvMCgallium_la_LIBADD += $(STATIC_TARGET_LIB_DEPS) $(TARGET_LIB_DEPS)
+libXvMCgallium_la_LIBADD += $(STATIC_TARGET_LIB_DEPS) $(TARGET_LIB_DEPS) \
+ $(TARGET_RADEON_WINSYS) $(TARGET_RADEON_COMMON)
else # HAVE_GALLIUM_STATIC_TARGETS