summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/xa/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/xa/Makefile.am')
-rw-r--r--src/gallium/targets/xa/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/gallium/targets/xa/Makefile.am b/src/gallium/targets/xa/Makefile.am
index 0d3945430a1..cb9fdc44716 100644
--- a/src/gallium/targets/xa/Makefile.am
+++ b/src/gallium/targets/xa/Makefile.am
@@ -66,6 +66,11 @@ libxatracker_la_LDFLAGS = \
$(GC_SECTIONS) \
$(LD_NO_UNDEFINED)
+if HAVE_LD_VERSION_SCRIPT
+libxatracker_la_LDFLAGS += \
+ -Wl,--version-script=$(top_srcdir)/src/gallium/targets/xa/xa.sym
+endif
+
if HAVE_MESA_LLVM
libxatracker_la_LIBADD += $(LLVM_LIBS)
libxatracker_la_LDFLAGS += $(LLVM_LDFLAGS)