summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/xa/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/xa/Makefile.am')
-rw-r--r--src/gallium/targets/xa/Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/src/gallium/targets/xa/Makefile.am b/src/gallium/targets/xa/Makefile.am
index e26b43aaa41..77d9fa68c20 100644
--- a/src/gallium/targets/xa/Makefile.am
+++ b/src/gallium/targets/xa/Makefile.am
@@ -53,13 +53,9 @@ endif
if HAVE_GALLIUM_STATIC_TARGETS
-STATIC_TARGET_CPPFLAGS =
-STATIC_TARGET_LIB_DEPS = \
- $(top_builddir)/src/loader/libloader.la
-
TARGET_DRIVERS =
TARGET_CPPFLAGS =
-TARGET_LIB_DEPS =
+TARGET_LIB_DEPS = $(top_builddir)/src/loader/libloader.la
include $(top_srcdir)/src/gallium/drivers/i915/Automake.inc
@@ -72,8 +68,8 @@ include $(top_srcdir)/src/gallium/drivers/svga/Automake.inc
include $(top_srcdir)/src/gallium/drivers/freedreno/Automake.inc
libxatracker_la_SOURCES += target.c
-libxatracker_la_CPPFLAGS = $(STATIC_TARGET_CPPFLAGS) $(TARGET_CPPFLAGS)
-libxatracker_la_LIBADD += $(STATIC_TARGET_LIB_DEPS) $(TARGET_LIB_DEPS)
+libxatracker_la_CPPFLAGS = $(TARGET_CPPFLAGS)
+libxatracker_la_LIBADD += $(TARGET_LIB_DEPS)
else # HAVE_GALLIUM_STATIC_TARGETS