summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/radeonsi/vdpau/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/radeonsi/vdpau/Makefile.am')
-rw-r--r--src/gallium/targets/radeonsi/vdpau/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/gallium/targets/radeonsi/vdpau/Makefile.am b/src/gallium/targets/radeonsi/vdpau/Makefile.am
index bda88e69997..b5e163509d7 100644
--- a/src/gallium/targets/radeonsi/vdpau/Makefile.am
+++ b/src/gallium/targets/radeonsi/vdpau/Makefile.am
@@ -33,6 +33,8 @@ AM_CPPFLAGS = \
vdpaudir = $(VDPAU_LIB_INSTALL_DIR)
vdpau_LTLIBRARIES = libvdpau_radeonsi.la
+EXPORTS = '^(vdp_imp_device_create_x11|radeon_drm_winsys_create)$$'
+
nodist_EXTRA_libvdpau_radeonsi_la_SOURCES = dummy.cpp
libvdpau_radeonsi_la_SOURCES = \
../drm_target.c \
@@ -41,6 +43,7 @@ libvdpau_radeonsi_la_SOURCES = \
libvdpau_radeonsi_la_LDFLAGS = \
-module \
-version-number $(VDPAU_MAJOR):$(VDPAU_MINOR) \
+ -export-symbols-regex $(EXPORTS) \
-shared \
-no-undefined