summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/r600/vdpau/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/r600/vdpau/Makefile.am')
-rw-r--r--src/gallium/targets/r600/vdpau/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/src/gallium/targets/r600/vdpau/Makefile.am b/src/gallium/targets/r600/vdpau/Makefile.am
index 1ff35e0d296..455d90f795b 100644
--- a/src/gallium/targets/r600/vdpau/Makefile.am
+++ b/src/gallium/targets/r600/vdpau/Makefile.am
@@ -30,6 +30,7 @@ AM_CFLAGS = \
vdpaudir = $(VDPAU_LIB_INSTALL_DIR)
vdpau_LTLIBRARIES = libvdpau_r600.la
+nodist_EXTRA_libvdpau_r600_la_SOURCES = dummy.cpp
libvdpau_r600_la_SOURCES = \
drm_target.c \
$(top_srcdir)/src/gallium/auxiliary/vl/vl_winsys_dri.c
@@ -44,8 +45,4 @@ libvdpau_r600_la_LIBADD = \
$(GALLIUM_VDPAU_LIB_DEPS) \
$(RADEON_LIBS)
-libvdpau_r600_la_LINK = $(CXXLINK) $(libvdpau_r600_la_LDFLAGS)
-# Mention a dummy pure C++ file to trigger generation of the $(LINK) variable
-nodist_EXTRA_libvdpau_r600_la_SOURCES = dummy-cpp.cpp
-
include $(top_srcdir)/install-gallium-links.mk