summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/r600/vdpau/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/r600/vdpau/Makefile.am')
-rw-r--r--src/gallium/targets/r600/vdpau/Makefile.am6
1 files changed, 1 insertions, 5 deletions
diff --git a/src/gallium/targets/r600/vdpau/Makefile.am b/src/gallium/targets/r600/vdpau/Makefile.am
index 7f43fbb187f..6e9f1174c9d 100644
--- a/src/gallium/targets/r600/vdpau/Makefile.am
+++ b/src/gallium/targets/r600/vdpau/Makefile.am
@@ -44,17 +44,13 @@ libvdpau_r600_la_LIBADD = \
$(GALLIUM_DRI_LIB_DEPS) \
$(RADEON_LIBS)
-if HAVE_MESA_LLVM
libvdpau_r600_la_LINK = $(CXXLINK) $(libvdpau_r600_la_LDFLAGS)
# Mention a dummy pure C++ file to trigger generation of the $(LINK) variable
nodist_EXTRA_libvdpau_r600_la_SOURCES = dummy-cpp.cpp
+if HAVE_MESA_LLVM
libvdpau_r600_la_LDFLAGS += $(LLVM_LDFLAGS)
libvdpau_r600_la_LIBADD += $(LLVM_LIBS)
-else
-libvdpau_r600_la_LINK = $(LINK) $(libvdpau_r600_la_LDFLAGS)
-# Mention a dummy pure C file to trigger generation of the $(LINK) variable
-nodist_EXTRA_libvdpau_r600_la_SOURCES = dummy-c.c
endif
# Provide compatibility with scripts for the old Mesa build system for