summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/r600/vdpau/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/r600/vdpau/Makefile.am')
-rw-r--r--src/gallium/targets/r600/vdpau/Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/src/gallium/targets/r600/vdpau/Makefile.am b/src/gallium/targets/r600/vdpau/Makefile.am
index 742df52074f..3a65a6fa771 100644
--- a/src/gallium/targets/r600/vdpau/Makefile.am
+++ b/src/gallium/targets/r600/vdpau/Makefile.am
@@ -20,6 +20,8 @@
# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
# DEALINGS IN THE SOFTWARE.
+# Note: Make sure VDPAU_EXPORTS is defined before including Automake.inc
+VDPAU_EXPORTS = '^(vdp_imp_device_create_x11|radeon_drm_winsys_create)$$'
include $(top_srcdir)/src/gallium/Automake.inc
AM_CFLAGS = \
@@ -28,18 +30,12 @@ AM_CFLAGS = \
vdpaudir = $(VDPAU_LIB_INSTALL_DIR)
vdpau_LTLIBRARIES = libvdpau_r600.la
-EXPORTS = '^(vdp_imp_device_create_x11|radeon_drm_winsys_create)$$'
-
libvdpau_r600_la_SOURCES = \
drm_target.c \
$(top_srcdir)/src/gallium/auxiliary/vl/vl_winsys_dri.c
libvdpau_r600_la_LDFLAGS = \
- -module \
- -version-number $(VDPAU_MAJOR):$(VDPAU_MINOR) \
- -export-symbols-regex $(EXPORTS) \
- -shared \
- -no-undefined
+ $(GALLIUM_VDPAU_LINKER_FLAGS)
libvdpau_r600_la_LIBADD = \
$(top_builddir)/src/gallium/auxiliary/libgallium.la \