summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/r600/dri/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/r600/dri/Makefile.am')
-rw-r--r--src/gallium/targets/r600/dri/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/gallium/targets/r600/dri/Makefile.am b/src/gallium/targets/r600/dri/Makefile.am
index 423ad0ea60e..5a1600ca8a1 100644
--- a/src/gallium/targets/r600/dri/Makefile.am
+++ b/src/gallium/targets/r600/dri/Makefile.am
@@ -40,14 +40,12 @@ dridir = $(DRI_DRIVER_INSTALL_DIR)
dri_LTLIBRARIES = r600_dri.la
r600_dri_la_SOURCES = \
- ../drm_target.c \
- $(top_srcdir)/src/mesa/drivers/dri/common/utils.c \
- $(top_srcdir)/src/mesa/drivers/dri/common/dri_util.c \
- $(top_srcdir)/src/mesa/drivers/dri/common/xmlconfig.c
+ ../drm_target.c
r600_dri_la_LDFLAGS = -module -avoid-version -shared -no-undefined
r600_dri_la_LIBADD = \
+ $(top_builddir)/src/mesa/drivers/dri/common/libdricommon.la \
$(top_builddir)/src/mesa/libmesagallium.la \
$(top_builddir)/src/gallium/auxiliary/libgallium.la \
$(top_builddir)/src/gallium/drivers/r600/libr600.la \