summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/r300/dri/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/r300/dri/Makefile.am')
-rw-r--r--src/gallium/targets/r300/dri/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/gallium/targets/r300/dri/Makefile.am b/src/gallium/targets/r300/dri/Makefile.am
index 4bd9ea4f6a9..e2becdbca65 100644
--- a/src/gallium/targets/r300/dri/Makefile.am
+++ b/src/gallium/targets/r300/dri/Makefile.am
@@ -37,7 +37,9 @@ nodist_EXTRA_r300_dri_la_SOURCES = dummy.cpp
r300_dri_la_SOURCES = \
drm_target.c
-r300_dri_la_LDFLAGS = $(GALLIUM_DRI_LINKER_FLAGS)
+r300_dri_la_LDFLAGS = \
+ $(GALLIUM_DRI_LINKER_FLAGS) \
+ -Wl,--dynamic-list=$(srcdir)/radeon.dyn
r300_dri_la_LIBADD = \
$(top_builddir)/src/mesa/drivers/dri/common/libdricommon.la \