summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/pipe-loader/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/pipe-loader/Makefile.am')
-rw-r--r--src/gallium/targets/pipe-loader/Makefile.am17
1 files changed, 7 insertions, 10 deletions
diff --git a/src/gallium/targets/pipe-loader/Makefile.am b/src/gallium/targets/pipe-loader/Makefile.am
index 1c2f31bc681..90b5760421f 100644
--- a/src/gallium/targets/pipe-loader/Makefile.am
+++ b/src/gallium/targets/pipe-loader/Makefile.am
@@ -148,16 +148,6 @@ pipe_vmwgfx_la_LDFLAGS += $(LLVM_LDFLAGS)
endif
endif
-if HAVE_GALLIUM_LLVMPIPE
-pipe_LTLIBRARIES += pipe_swrast.la
-pipe_swrast_la_SOURCES = pipe_swrast.c
-nodist_EXTRA_pipe_swrast_la_SOURCES = dummy.cpp
-pipe_swrast_la_LIBADD = \
- $(PIPE_LIBS) \
- $(top_builddir)/src/gallium/drivers/llvmpipe/libllvmpipe.la \
- $(LLVM_LIBS)
-pipe_swrast_la_LDFLAGS = -no-undefined -avoid-version -module $(LLVM_LDFLAGS)
-else
if HAVE_GALLIUM_SOFTPIPE
pipe_LTLIBRARIES += pipe_swrast.la
pipe_swrast_la_SOURCES = pipe_swrast.c
@@ -165,5 +155,12 @@ pipe_swrast_la_LIBADD = \
$(PIPE_LIBS) \
$(top_builddir)/src/gallium/drivers/softpipe/libsoftpipe.la
pipe_swrast_la_LDFLAGS = -no-undefined -avoid-version -module
+if HAVE_GALLIUM_LLVMPIPE
+nodist_EXTRA_pipe_swrast_la_SOURCES = dummy.cpp
+
+pipe_swrast_la_LIBADD += \
+ $(top_builddir)/src/gallium/drivers/softpipe/libllvmpipe.la \
+ $(LLVM_LIBS)
+pipe_swrast_la_LDFLAGS += $(LLVM_LDFLAGS)
endif
endif