summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/pipe-loader/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/pipe-loader/Makefile.am')
-rw-r--r--src/gallium/targets/pipe-loader/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/src/gallium/targets/pipe-loader/Makefile.am b/src/gallium/targets/pipe-loader/Makefile.am
index 5022550cf67..3d73a51535a 100644
--- a/src/gallium/targets/pipe-loader/Makefile.am
+++ b/src/gallium/targets/pipe-loader/Makefile.am
@@ -36,9 +36,19 @@ AM_CPPFLAGS = \
pipedir = $(libdir)/gallium-pipe
pipe_LTLIBRARIES =
-PIPE_LIBS = \
+PIPE_LIBS =
+
+if NEED_GALLIUM_VL
+PIPE_LIBS += \
+ $(top_builddir)/src/gallium/auxiliary/libgalliumvl.la
+else
+PIPE_LIBS += \
+ $(top_builddir)/src/gallium/auxiliary/libgalliumvl_stub.la
+endif
+
+PIPE_LIBS += \
$(top_builddir)/src/gallium/auxiliary/libgallium.la \
- $(top_builddir)/src/util/libmesautil.la \
+ $(top_builddir)/src/util/libmesautil.la \
$(top_builddir)/src/gallium/drivers/rbug/librbug.la \
$(top_builddir)/src/gallium/drivers/trace/libtrace.la \
$(top_builddir)/src/gallium/drivers/galahad/libgalahad.la \