summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/osmesa/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/osmesa/meson.build')
-rw-r--r--src/gallium/targets/osmesa/meson.build5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/gallium/targets/osmesa/meson.build b/src/gallium/targets/osmesa/meson.build
index e51c54f8bc4..b4ae8f4b6ec 100644
--- a/src/gallium/targets/osmesa/meson.build
+++ b/src/gallium/targets/osmesa/meson.build
@@ -35,7 +35,7 @@ endif
libosmesa = shared_library(
osmesa_lib_name,
'target.c',
- c_args : [c_vis_args, '-DGALLIUM_TRACE'],
+ c_args : [c_vis_args],
cpp_args : cpp_vis_args,
link_args : [ld_args_gc_sections, osmesa_link_args],
include_directories : [
@@ -45,8 +45,7 @@ libosmesa = shared_library(
link_depends : osmesa_link_deps,
link_whole : [libosmesa_st],
link_with : [
- libmesa_gallium, libgallium, libglapi_static, libws_null, libtrace,
- osmesa_link_with,
+ libmesa_gallium, libgallium, libglapi_static, libws_null, osmesa_link_with,
],
dependencies : [
dep_selinux, dep_thread, dep_clock, dep_unwind,