aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/osmesa/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/osmesa/meson.build')
-rw-r--r--src/gallium/targets/osmesa/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/gallium/targets/osmesa/meson.build b/src/gallium/targets/osmesa/meson.build
index e873e311aa0..1612908d016 100644
--- a/src/gallium/targets/osmesa/meson.build
+++ b/src/gallium/targets/osmesa/meson.build
@@ -62,3 +62,12 @@ pkg.generate(
libraries : libosmesa,
libraries_private : gl_priv_libs,
)
+
+if with_tests
+ test('osmesa-render',
+ executable('osmesa-render',
+ 'test-render.c',
+ include_directories : inc_common,
+ link_with: libosmesa),
+ suite: 'gallium')
+endif