summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/osmesa/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/osmesa/Makefile.am')
-rw-r--r--src/gallium/targets/osmesa/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/gallium/targets/osmesa/Makefile.am b/src/gallium/targets/osmesa/Makefile.am
index 2b133c44cb9..651fc5d2b45 100644
--- a/src/gallium/targets/osmesa/Makefile.am
+++ b/src/gallium/targets/osmesa/Makefile.am
@@ -39,7 +39,12 @@ lib_LTLIBRARIES = lib@[email protected]
nodist_EXTRA_lib@OSMESA_LIB@_la_SOURCES = dummy.cpp
lib@OSMESA_LIB@_la_SOURCES = target.c
-lib@OSMESA_LIB@_la_LDFLAGS = -module -version-number @OSMESA_VERSION@ -no-undefined
+lib@OSMESA_LIB@_la_LDFLAGS = \
+ -module \
+ -no-undefined \
+ -version-number @OSMESA_VERSION@ \
+ -Wl,--no-undefined
+
if HAVE_SHARED_GLAPI
SHARED_GLAPI_LIB = $(top_builddir)/src/mapi/shared-glapi/libglapi.la