aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/opencl/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/opencl/meson.build')
-rw-r--r--src/gallium/targets/opencl/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/gallium/targets/opencl/meson.build b/src/gallium/targets/opencl/meson.build
index 650a2054cfb..dd97c91b1f6 100644
--- a/src/gallium/targets/opencl/meson.build
+++ b/src/gallium/targets/opencl/meson.build
@@ -39,8 +39,9 @@ libopencl = shared_library(
link_args : [ld_args_gc_sections, opencl_link_args],
link_depends : opencl_link_deps,
link_whole : libclover,
- link_with : [libpipe_loader_dynamic, libgallium, libmesa_util],
+ link_with : [libpipe_loader_dynamic, libgallium],
dependencies : [
+ idep_mesautil,
dep_thread, dep_clock, dep_dl, dep_unwind, dep_elf, dep_expat,
cpp.find_library('clangCodeGen', dirs : llvm_libdir),
cpp.find_library('clangFrontendTool', dirs : llvm_libdir),