summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/opencl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/opencl/Makefile.am')
-rw-r--r--src/gallium/targets/opencl/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/gallium/targets/opencl/Makefile.am b/src/gallium/targets/opencl/Makefile.am
index 55a73b49ecd..7f2854d56fe 100644
--- a/src/gallium/targets/opencl/Makefile.am
+++ b/src/gallium/targets/opencl/Makefile.am
@@ -6,12 +6,13 @@ lib@OPENCL_LIBNAME@_la_LDFLAGS = \
$(LLVM_LDFLAGS) \
-no-undefined \
-version-number 1:0 \
-if HAVE_LD_VERSION_SCRIPT
- -Wl,--version-script=$(top_srcdir)/src/gallium/targets/opencl/opencl.sym \
-endif
$(GC_SECTIONS) \
$(LD_NO_UNDEFINED)
+if HAVE_LD_VERSION_SCRIPT
+lib@OPENCL_LIBNAME@_la_LDFLAGS += \
+ -Wl,--version-script=$(top_srcdir)/src/gallium/targets/opencl/opencl.sym
+endif
lib@OPENCL_LIBNAME@_la_LIBADD = \
$(top_builddir)/src/gallium/auxiliary/pipe-loader/libpipe_loader_client.la \