summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/opencl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/opencl/Makefile.am')
-rw-r--r--src/gallium/targets/opencl/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/gallium/targets/opencl/Makefile.am b/src/gallium/targets/opencl/Makefile.am
index e82889e0f46..7b32a099b29 100644
--- a/src/gallium/targets/opencl/Makefile.am
+++ b/src/gallium/targets/opencl/Makefile.am
@@ -28,6 +28,11 @@ lib@OPENCL_LIBNAME@_la_LIBADD = \
-lclangBasic \
$(LLVM_LIBS)
+if HAVE_DRI
+lib@OPENCL_LIBNAME@_la_LIBADD += \
+ $(top_builddir)/src/gallium/winsys/sw/dri/libswdri.la
+endif
+
if NEED_PIPE_LOADER_XLIB
lib@OPENCL_LIBNAME@_la_LIBADD += \
$(top_builddir)/src/gallium/winsys/sw/xlib/libws_xlib.la \