aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/omx/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/omx/meson.build')
-rw-r--r--src/gallium/targets/omx/meson.build51
1 files changed, 51 insertions, 0 deletions
diff --git a/src/gallium/targets/omx/meson.build b/src/gallium/targets/omx/meson.build
new file mode 100644
index 00000000000..6811e6ff904
--- /dev/null
+++ b/src/gallium/targets/omx/meson.build
@@ -0,0 +1,51 @@
+# Copyright © 2017-2018 Intel Corporation
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+# TODO: support non-static targets
+# Static targets are always enabled in autotools (unless you modify
+# configure.ac)
+
+omx_link_args = []
+omx_link_depends = []
+
+if with_ld_version_script
+ omx_link_args += ['-Wl,--version-script', join_paths(meson.current_source_dir(), 'omx.sym')]
+ omx_link_depends += files('omx.sym')
+endif
+
+libomx_gallium = shared_library(
+ 'omx_mesa',
+ 'target.c',
+ c_args : c_vis_args,
+ cpp_args : cpp_vis_args,
+ link_args : [omx_link_args, ld_args_gc_sections],
+ include_directories : [
+ inc_common, inc_util, inc_gallium_winsys, inc_gallium_drivers,
+ ],
+ link_whole : [libomx_st],
+ link_with : [
+ libgalliumvlwinsys, libgalliumvl, libgallium, libmesa_util,
+ libpipe_loader_static, libws_null, libwsw, libswdri, libswkmsdri,
+ ],
+ link_depends : omx_link_depends,
+ dependencies : [dep_thread, driver_r600, driver_radeonsi, driver_nouveau],
+ install : true,
+ install_dir : omx_drivers_path,
+)