summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/omx-nouveau/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/omx-nouveau/Makefile.am')
-rw-r--r--src/gallium/targets/omx-nouveau/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/src/gallium/targets/omx-nouveau/Makefile.am b/src/gallium/targets/omx-nouveau/Makefile.am
new file mode 100644
index 00000000000..40ae06ca859
--- /dev/null
+++ b/src/gallium/targets/omx-nouveau/Makefile.am
@@ -0,0 +1,43 @@
+# Copyright © 2012 Intel Corporation
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+# DEALINGS IN THE SOFTWARE.
+
+include $(top_srcdir)/src/gallium/Automake.inc
+
+AM_CFLAGS = \
+ $(GALLIUM_VIDEO_CFLAGS)
+
+omxdir = $(OMX_LIB_INSTALL_DIR)
+omx_LTLIBRARIES = libomx_nouveau.la
+
+nodist_EXTRA_libomx_nouveau_la_SOURCES = dummy.cpp
+libomx_nouveau_la_SOURCES = \
+ target.c \
+ $(top_srcdir)/src/gallium/auxiliary/vl/vl_winsys_dri.c
+
+libomx_nouveau_la_LDFLAGS = $(GALLIUM_OMX_LINKER_FLAGS)
+
+libomx_nouveau_la_LIBADD = \
+ $(top_builddir)/src/gallium/winsys/nouveau/drm/libnouveaudrm.la \
+ $(top_builddir)/src/gallium/drivers/nouveau/libnouveau.la \
+ $(GALLIUM_OMX_LIB_DEPS) \
+ $(LIBDRM_LIBS) \
+ $(NOUVEAU_LIBS)