aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/libgl-xlib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/libgl-xlib/Makefile.am')
-rw-r--r--src/gallium/targets/libgl-xlib/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/gallium/targets/libgl-xlib/Makefile.am b/src/gallium/targets/libgl-xlib/Makefile.am
index cc382db08b2..d7aec7b5b50 100644
--- a/src/gallium/targets/libgl-xlib/Makefile.am
+++ b/src/gallium/targets/libgl-xlib/Makefile.am
@@ -44,7 +44,10 @@ lib_LTLIBRARIES = libGL.la
nodist_EXTRA_libGL_la_SOURCES = dummy.cpp
libGL_la_SOURCES = xlib.c
-libGL_la_LDFLAGS = -version-number $(GL_MAJOR):$(GL_MINOR):$(GL_TINY) -no-undefined
+libGL_la_LDFLAGS = \
+ -no-undefined \
+ -version-number $(GL_MAJOR):$(GL_MINOR):$(GL_TINY) \
+ -Wl,--no-undefined
libGL_la_LIBADD = \
$(top_builddir)/src/gallium/state_trackers/glx/xlib/libxlib.la \