summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/graw-xlib/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/graw-xlib/meson.build')
-rw-r--r--src/gallium/targets/graw-xlib/meson.build33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/gallium/targets/graw-xlib/meson.build b/src/gallium/targets/graw-xlib/meson.build
new file mode 100644
index 00000000000..4716c543cbc
--- /dev/null
+++ b/src/gallium/targets/graw-xlib/meson.build
@@ -0,0 +1,33 @@
+# Copyright © 2018 Intel Corporation
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+libgraw_xlib = shared_library(
+ 'graw_xlib',
+ ['graw_xlib.c'],
+ c_args : ['-DGALLIUM_TRACE', '-DGALLIUM_RBUG'],
+ include_directories : [inc_common, inc_gallium_drivers, inc_gallium_winsys],
+ link_with : [
+ libgraw_util, libtrace, librbug, libmesa_util, libgallium, libws_xlib
+ ],
+ dependencies : [dep_thread, driver_swrast],
+ version : '1.0',
+)
+
+libgraw = libgraw_xlib