summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/gbm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/gbm/Makefile.am')
-rw-r--r--src/gallium/targets/gbm/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/gallium/targets/gbm/Makefile.am b/src/gallium/targets/gbm/Makefile.am
index ccfddacd865..5efc0e4de3f 100644
--- a/src/gallium/targets/gbm/Makefile.am
+++ b/src/gallium/targets/gbm/Makefile.am
@@ -67,12 +67,14 @@ gbm_gallium_drm_la_LDFLAGS = \
-module \
-no-undefined \
-avoid-version \
-if HAVE_LD_VERSION_SCRIPT
- -Wl,--version-script=$(top_srcdir)/src/gallium/targets/gbm/gbm.sym \
-endif
$(GC_SECTIONS) \
$(LD_NO_UNDEFINED)
+if HAVE_LD_VERSION_SCRIPT
+gbm_gallium_drm_la_LDFLAGS += \
+ -Wl,--version-script=$(top_srcdir)/src/gallium/targets/gbm/gbm.sym
+endif
+
if HAVE_MESA_LLVM
gbm_gallium_drm_la_LIBADD += $(LLVM_LIBS)
gbm_gallium_drm_la_LDFLAGS += $(LLVM_LDFLAGS)