summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/gbm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/gbm/Makefile.am')
-rw-r--r--src/gallium/targets/gbm/Makefile.am16
1 files changed, 7 insertions, 9 deletions
diff --git a/src/gallium/targets/gbm/Makefile.am b/src/gallium/targets/gbm/Makefile.am
index 34fd24379c0..1271825f96b 100644
--- a/src/gallium/targets/gbm/Makefile.am
+++ b/src/gallium/targets/gbm/Makefile.am
@@ -56,6 +56,10 @@ STATIC_TARGET_CPPFLAGS =
STATIC_TARGET_LIB_DEPS = \
$(top_builddir)/src/loader/libloader.la
+TARGET_DRIVERS =
+TARGET_CPPFLAGS =
+TARGET_LIB_DEPS =
+
if HAVE_GALLIUM_I915
STATIC_TARGET_CPPFLAGS += -DGALLIUM_I915
STATIC_TARGET_LIB_DEPS += \
@@ -72,13 +76,7 @@ STATIC_TARGET_LIB_DEPS += \
$(INTEL_LIBS)
endif
-if HAVE_GALLIUM_NOUVEAU
-STATIC_TARGET_CPPFLAGS += -DGALLIUM_NOUVEAU
-STATIC_TARGET_LIB_DEPS += \
- $(top_builddir)/src/gallium/winsys/nouveau/drm/libnouveaudrm.la \
- $(top_builddir)/src/gallium/drivers/nouveau/libnouveau.la \
- $(NOUVEAU_LIBS)
-endif
+include $(top_srcdir)/src/gallium/drivers/nouveau/Automake.inc
if NEED_RADEON_DRM_WINSYS
STATIC_TARGET_LIB_DEPS += \
@@ -128,8 +126,8 @@ STATIC_TARGET_LIB_DEPS += \
endif
gbm_gallium_drm_la_SOURCES += target.c
-gbm_gallium_drm_la_CPPFLAGS = $(STATIC_TARGET_CPPFLAGS)
-gbm_gallium_drm_la_LIBADD += $(STATIC_TARGET_LIB_DEPS)
+gbm_gallium_drm_la_CPPFLAGS = $(STATIC_TARGET_CPPFLAGS) $(TARGET_CPPFLAGS)
+gbm_gallium_drm_la_LIBADD += $(STATIC_TARGET_LIB_DEPS) $(TARGET_LIB_DEPS)
else # HAVE_GALLIUM_STATIC_TARGETS
gbm_gallium_drm_la_LIBADD += \