summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/egl-static/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/egl-static/Makefile.am')
-rw-r--r--src/gallium/targets/egl-static/Makefile.am10
1 files changed, 2 insertions, 8 deletions
diff --git a/src/gallium/targets/egl-static/Makefile.am b/src/gallium/targets/egl-static/Makefile.am
index 58ecf697ce9..a133cd1b6c1 100644
--- a/src/gallium/targets/egl-static/Makefile.am
+++ b/src/gallium/targets/egl-static/Makefile.am
@@ -69,10 +69,7 @@ egl_gallium_la_LIBADD = \
$(top_builddir)/src/gallium/state_trackers/egl/libegl.la \
$(top_builddir)/src/egl/main/libEGL.la \
$(top_builddir)/src/loader/libloader.la \
- $(CLOCK_LIB) \
- $(DLOPEN_LIBS) \
- $(PTHREAD_LIBS) \
- -lm
+ $(GALLIUM_COMMON_LIB_DEPS)
if HAVE_MESA_LLVM
AM_LDFLAGS += $(LLVM_LDFLAGS)
@@ -139,10 +136,7 @@ st_GL_la_LIBADD = \
$(top_builddir)/src/mesa/libmesagallium.la \
$(top_builddir)/src/gallium/auxiliary/libgallium.la \
$(top_builddir)/src/mapi/glapi/libglapi.la \
- $(CLOCK_LIB) \
- $(DLOPEN_LIBS) \
- $(PTHREAD_LIBS) \
- -lm
+ $(GALLIUM_COMMON_LIB_DEPS)
endif
endif