summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/dri/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/dri/meson.build')
-rw-r--r--src/gallium/targets/dri/meson.build13
1 files changed, 11 insertions, 2 deletions
diff --git a/src/gallium/targets/dri/meson.build b/src/gallium/targets/dri/meson.build
index fd758e1b60a..541234f8032 100644
--- a/src/gallium/targets/dri/meson.build
+++ b/src/gallium/targets/dri/meson.build
@@ -83,11 +83,20 @@ if with_gallium_softpipe
endif
if with_gallium_vc4
gallium_dri_c_args += '-DGALLIUM_VC4'
- gallium_dri_link_with += [libvc4, libvc4winsys, libbroadcom_cle]
+ gallium_dri_link_with += [libvc4, libvc4winsys]
gallium_dri_drivers += 'vc4_dri.so'
endif
+if with_gallium_vc5
+ gallium_dri_c_args += '-DGALLIUM_VC5'
+ gallium_dri_link_with += [libvc5, libvc5winsys, libbroadcom_vc5]
+ gallium_dri_drivers += 'vc5_dri.so'
+endif
+
+if with_gallium_vc4 or with_gallium_vc5
+ gallium_dri_link_with += libbroadcom_cle
+endif
-if with_gallium_vc4 or with_gallium_radeonsi
+if with_gallium_vc4 or with_gallium_vc5 or with_gallium_radeonsi
gallium_dri_link_with += libnir
endif