summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/dri/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/dri/Makefile.am')
-rw-r--r--src/gallium/targets/dri/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/gallium/targets/dri/Makefile.am b/src/gallium/targets/dri/Makefile.am
index cb1206452e4..f9d34828452 100644
--- a/src/gallium/targets/dri/Makefile.am
+++ b/src/gallium/targets/dri/Makefile.am
@@ -1,6 +1,10 @@
include $(top_srcdir)/src/gallium/Automake.inc
AM_CFLAGS = \
+ -I$(top_srcdir)/src/mapi \
+ -I$(top_srcdir)/src/mesa \
+ -I$(top_srcdir)/src/mesa/drivers/dri/common \
+ -I$(top_srcdir)/src/gallium/state_trackers/dri/common \
$(GALLIUM_TARGET_CFLAGS)
AM_CPPFLAGS = \
@@ -9,6 +13,11 @@ AM_CPPFLAGS = \
-DGALLIUM_RBUG \
-DGALLIUM_TRACE
+if HAVE_GALLIUM_NOUVEAU
+AM_CPPFLAGS += \
+ -DDRI_TARGET
+endif
+
dridir = $(DRI_DRIVER_INSTALL_DIR)
dri_LTLIBRARIES = gallium_dri.la