summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/dri/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/dri/Makefile.am')
-rw-r--r--src/gallium/targets/dri/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/gallium/targets/dri/Makefile.am b/src/gallium/targets/dri/Makefile.am
index 88242a97fa6..cb1206452e4 100644
--- a/src/gallium/targets/dri/Makefile.am
+++ b/src/gallium/targets/dri/Makefile.am
@@ -45,6 +45,12 @@ gallium_dri_la_LIBADD = \
if HAVE_GALLIUM_STATIC_TARGETS
+# XXX: Temporary allow duplicated symbols, as the loader pulls in xmlconfig.c
+# which already provides driParse* and driQuery* amongst others.
+# Remove this hack as we come up with a cleaner solution.
+gallium_dri_la_LDFLAGS += \
+ -Wl,--allow-multiple-definition
+
MEGADRIVERS =
STATIC_TARGET_CPPFLAGS =
STATIC_TARGET_LIB_DEPS = \