summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/dri-vmwgfx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/dri-vmwgfx/Makefile.am')
-rw-r--r--src/gallium/targets/dri-vmwgfx/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/gallium/targets/dri-vmwgfx/Makefile.am b/src/gallium/targets/dri-vmwgfx/Makefile.am
index ca7df65ada8..f7008ab8179 100644
--- a/src/gallium/targets/dri-vmwgfx/Makefile.am
+++ b/src/gallium/targets/dri-vmwgfx/Makefile.am
@@ -40,14 +40,12 @@ dri_LTLIBRARIES = vmwgfx_dri.la
vmwgfx_dri_la_SOURCES = \
target.c \
- vmw_powf.c \
- $(top_srcdir)/src/mesa/drivers/dri/common/utils.c \
- $(top_srcdir)/src/mesa/drivers/dri/common/dri_util.c \
- $(top_srcdir)/src/mesa/drivers/dri/common/xmlconfig.c
+ vmw_powf.c
vmwgfx_dri_la_LDFLAGS = -module -avoid-version -shared -no-undefined
vmwgfx_dri_la_LIBADD = \
+ $(top_builddir)/src/mesa/drivers/dri/common/libdricommon.la \
$(top_builddir)/src/mesa/libmesagallium.la \
$(top_builddir)/src/gallium/auxiliary/libgallium.la \
$(top_builddir)/src/gallium/state_trackers/dri/drm/libdridrm.la \