summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/dri-ilo/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/dri-ilo/Makefile.am')
-rw-r--r--src/gallium/targets/dri-ilo/Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/src/gallium/targets/dri-ilo/Makefile.am b/src/gallium/targets/dri-ilo/Makefile.am
index 7761f338cba..88233f651ba 100644
--- a/src/gallium/targets/dri-ilo/Makefile.am
+++ b/src/gallium/targets/dri-ilo/Makefile.am
@@ -39,17 +39,14 @@ AM_CPPFLAGS = \
noinst_LTLIBRARIES = ilo_dri.la
-ilo_dri_la_SOURCES = \
- target.c \
- $(top_srcdir)/src/mesa/drivers/dri/common/utils.c \
- $(top_srcdir)/src/mesa/drivers/dri/common/dri_util.c \
- $(top_srcdir)/src/mesa/drivers/dri/common/xmlconfig.c
+ilo_dri_la_SOURCES = target.c
# need -rpath to create a noinst shared library
ilo_dri_la_LDFLAGS = -module -avoid-version -shared -no-undefined \
-rpath $(abs_builddir)
ilo_dri_la_LIBADD = \
+ $(top_builddir)/src/mesa/drivers/dri/common/libdricommon.la \
$(top_builddir)/src/mesa/libmesagallium.la \
$(top_builddir)/src/gallium/auxiliary/libgallium.la \
$(top_builddir)/src/gallium/state_trackers/dri/drm/libdridrm.la \