summaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/dri-i915/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/dri-i915/Makefile.am')
-rw-r--r--src/gallium/targets/dri-i915/Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/src/gallium/targets/dri-i915/Makefile.am b/src/gallium/targets/dri-i915/Makefile.am
index ce6be788f31..e1c6ecab4b4 100644
--- a/src/gallium/targets/dri-i915/Makefile.am
+++ b/src/gallium/targets/dri-i915/Makefile.am
@@ -40,15 +40,12 @@ AM_CPPFLAGS = \
dridir = $(DRI_DRIVER_INSTALL_DIR)
dri_LTLIBRARIES = i915_dri.la
-i915_dri_la_SOURCES = \
- target.c \
- $(top_srcdir)/src/mesa/drivers/dri/common/utils.c \
- $(top_srcdir)/src/mesa/drivers/dri/common/dri_util.c \
- $(top_srcdir)/src/mesa/drivers/dri/common/xmlconfig.c
+i915_dri_la_SOURCES = target.c
i915_dri_la_LDFLAGS = -module -avoid-version -shared -no-undefined
i915_dri_la_LIBADD = \
+ $(top_builddir)/src/mesa/drivers/dri/common/libdricommon.la \
$(top_builddir)/src/mesa/libmesagallium.la \
$(top_builddir)/src/gallium/auxiliary/libgallium.la \
$(top_builddir)/src/gallium/state_trackers/dri/drm/libdridrm.la \