aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/Makefile.am')
-rw-r--r--src/gallium/targets/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/src/gallium/targets/Makefile.am b/src/gallium/targets/Makefile.am
index d86cd33af94..1a44c56ccfe 100644
--- a/src/gallium/targets/Makefile.am
+++ b/src/gallium/targets/Makefile.am
@@ -22,6 +22,10 @@
SUBDIRS =
+if HAVE_DRI2
+SUBDIRS += dri
+endif
+
if HAVE_X11_DRIVER
SUBDIRS += libgl-xlib
endif
@@ -96,12 +100,6 @@ SUBDIRS += radeonsi/dri
endif
endif
-if HAVE_GALLIUM_NOUVEAU
-if HAVE_DRI2
-SUBDIRS += dri-nouveau
-endif
-endif
-
if HAVE_GALLIUM_SOFTPIPE
if HAVE_DRISW
SUBDIRS += dri-swrast