summaryrefslogtreecommitdiffstats
path: root/src/gallium/state_trackers/vdpau/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/state_trackers/vdpau/Makefile.am')
-rw-r--r--src/gallium/state_trackers/vdpau/Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/src/gallium/state_trackers/vdpau/Makefile.am b/src/gallium/state_trackers/vdpau/Makefile.am
new file mode 100644
index 00000000000..f300640752b
--- /dev/null
+++ b/src/gallium/state_trackers/vdpau/Makefile.am
@@ -0,0 +1,55 @@
+# Copyright © 2012 Intel Corporation
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+# DEALINGS IN THE SOFTWARE.
+
+include $(top_srcdir)/src/gallium/Automake.inc
+
+VDPAU_MAJOR = 1
+VDPAU_MINOR = 0
+
+AM_CFLAGS = \
+ $(GALLIUM_CFLAGS) \
+ $(VDPAU_CFLAGS)
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include \
+ -DVER_MAJOR=$(VDPAU_MAJOR) \
+ -DVER_MINOR=$(VDPAU_MINOR)
+
+noinst_LTLIBRARIES = libvdpautracker.la
+
+libvdpautracker_la_SOURCES = \
+ htab.c \
+ ftab.c \
+ device.c \
+ query.c \
+ surface.c \
+ decode.c \
+ presentation.c \
+ bitmap.c \
+ output.c \
+ preemption.c \
+ mixer.c
+
+#XXX: Delete this when all targets that rely on vdpautracker are converted to automake.
+all-local: libvdpautracker.la
+ ln -f $(builddir)/.libs/libvdpautracker.a $(builddir)/libvdpautracker.a
+
+CLEANFILES = libvdpautracker.a