summaryrefslogtreecommitdiffstats
path: root/src/gallium/state_trackers/osmesa/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/state_trackers/osmesa/meson.build')
-rw-r--r--src/gallium/state_trackers/osmesa/meson.build11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/gallium/state_trackers/osmesa/meson.build b/src/gallium/state_trackers/osmesa/meson.build
index 1e49de875b1..e5848fd9934 100644
--- a/src/gallium/state_trackers/osmesa/meson.build
+++ b/src/gallium/state_trackers/osmesa/meson.build
@@ -1,4 +1,4 @@
-# Copyright © 2017 Intel Corporation
+# Copyright © 2017-2018 Intel Corporation
# Permission is hereby granted, free of charge, to any person obtaining a copy
# of this software and associated documentation files (the "Software"), to deal
@@ -18,9 +18,18 @@
# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
# SOFTWARE.
+osmesa_st_c_args = []
+if with_platform_windows
+ osmesa_st_c_args += ['-DBUILD_GL32', '-DWIN32_LEAN_AND_MEAN']
+ if not with_shared_glapi
+ osmesa_st_c_args += ['-D_GLAPI_NO_EXPORTS']
+ endif
+endif
+
libosmesa_st = static_library(
'osmesa_st',
'osmesa.c',
+ c_args : osmesa_st_c_args,
include_directories : [
inc_include, inc_src, inc_gallium, inc_gallium_aux, inc_mapi, inc_mesa,
],