summaryrefslogtreecommitdiffstats
path: root/src/gallium/state_trackers/omx/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/state_trackers/omx/meson.build')
-rw-r--r--src/gallium/state_trackers/omx/meson.build38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/gallium/state_trackers/omx/meson.build b/src/gallium/state_trackers/omx/meson.build
new file mode 100644
index 00000000000..d17332553ff
--- /dev/null
+++ b/src/gallium/state_trackers/omx/meson.build
@@ -0,0 +1,38 @@
+# Copyright © 2017 Intel Corporation
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+if gallium_omx == 'bellagio'
+files_omx = files(
+ 'bellagio/entrypoint.c',
+ 'bellagio/vid_dec.c',
+ 'bellagio/vid_dec_mpeg12.c',
+ 'bellagio/vid_dec_h264.c',
+ 'bellagio/vid_dec_h265.c',
+ 'bellagio/vid_enc.c'
+)
+endif
+
+libomx_st = static_library(
+ 'omx_st',
+ files_omx,
+ c_args : [c_vis_args],
+ include_directories : [inc_common],
+ dependencies : [dep_omx, dep_x11_xcb, dep_xcb, dep_xcb_dri2, dep_xcb_dri3],
+)