summaryrefslogtreecommitdiffstats
path: root/src/gallium/state_trackers/egl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/state_trackers/egl/Makefile.am')
-rw-r--r--src/gallium/state_trackers/egl/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/gallium/state_trackers/egl/Makefile.am b/src/gallium/state_trackers/egl/Makefile.am
index b7dcdabffef..828bf13e27c 100644
--- a/src/gallium/state_trackers/egl/Makefile.am
+++ b/src/gallium/state_trackers/egl/Makefile.am
@@ -88,3 +88,23 @@ AM_CPPFLAGS += \
-I$(top_srcdir)/src/gallium/winsys/sw \
-DHAVE_NULL_BACKEND
endif
+
+if HAVE_OPENGL
+AM_CPPFLAGS += \
+ -DFEATURE_GL=1
+endif
+
+if HAVE_OPENGL_ES1
+AM_CPPFLAGS += \
+ -DFEATURE_ES1=1
+endif
+
+if HAVE_OPENGL_ES2
+AM_CPPFLAGS += \
+ -DFEATURE_ES2=1
+endif
+
+if HAVE_OPENVG
+AM_CPPFLAGS += \
+ -DFEATURE_VG=1
+endif