summaryrefslogtreecommitdiffstats
path: root/src/gallium/state_trackers/clover/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/state_trackers/clover/Makefile.am')
-rw-r--r--src/gallium/state_trackers/clover/Makefile.am61
1 files changed, 0 insertions, 61 deletions
diff --git a/src/gallium/state_trackers/clover/Makefile.am b/src/gallium/state_trackers/clover/Makefile.am
deleted file mode 100644
index 32ed04f6a2c..00000000000
--- a/src/gallium/state_trackers/clover/Makefile.am
+++ /dev/null
@@ -1,61 +0,0 @@
-include Makefile.sources
-
-AM_CPPFLAGS = \
- -I$(top_srcdir)/include \
- -I$(top_builddir)/src \
- -I$(top_srcdir)/src \
- -I$(top_srcdir)/src/gallium/include \
- -I$(top_srcdir)/src/gallium/drivers \
- -I$(top_srcdir)/src/gallium/auxiliary \
- -I$(top_srcdir)/src/gallium/winsys
-
-if HAVE_CLOVER_ICD
-AM_CPPFLAGS += -DHAVE_CLOVER_ICD
-else
-# Only install the headers if we are building a stand-alone implementation
-cldir = $(includedir)/CL
-cl_HEADERS = \
- $(top_srcdir)/include/CL/cl.h \
- $(top_srcdir)/include/CL/cl.hpp \
- $(top_srcdir)/include/CL/cl2.hpp \
- $(top_srcdir)/include/CL/cl_d3d10.h \
- $(top_srcdir)/include/CL/cl_d3d11.h \
- $(top_srcdir)/include/CL/cl_dx9_media_sharing.h \
- $(top_srcdir)/include/CL/cl_dx9_media_sharing_intel.h \
- $(top_srcdir)/include/CL/cl_egl.h \
- $(top_srcdir)/include/CL/cl_ext.h \
- $(top_srcdir)/include/CL/cl_ext_intel.h \
- $(top_srcdir)/include/CL/cl_gl.h \
- $(top_srcdir)/include/CL/cl_gl_ext.h \
- $(top_srcdir)/include/CL/cl_platform.h \
- $(top_srcdir)/include/CL/cl_va_api_media_sharing_intel.h \
- $(top_srcdir)/include/CL/cl_version.h \
- $(top_srcdir)/include/CL/opencl.h
-endif
-
-noinst_LTLIBRARIES = libclover.la libclllvm.la
-
-libclllvm_la_CXXFLAGS = \
- $(CXX11_CXXFLAGS) \
- $(VISIBILITY_CXXFLAGS) \
- $(LLVM_CXXFLAGS) \
- $(CLOVER_STD_OVERRIDE) \
- $(DEFINES) \
- $(LIBELF_CFLAGS) \
- -DLIBCLC_INCLUDEDIR=\"$(LIBCLC_INCLUDEDIR)/\" \
- -DLIBCLC_LIBEXECDIR=\"$(LIBCLC_LIBEXECDIR)/\" \
- -DCLANG_RESOURCE_DIR=\"$(CLANG_RESOURCE_DIR)\"
-
-libclllvm_la_SOURCES = $(LLVM_SOURCES)
-
-libclover_la_CXXFLAGS = \
- $(CXX11_CXXFLAGS) \
- $(CLOVER_STD_OVERRIDE) \
- $(VISIBILITY_CXXFLAGS)
-
-libclover_la_LIBADD = \
- libclllvm.la
-
-libclover_la_SOURCES = $(CPP_SOURCES)
-
-EXTRA_DIST = Doxyfile meson.build