summaryrefslogtreecommitdiffstats
path: root/src/gallium/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/meson.build')
-rw-r--r--src/gallium/meson.build12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/gallium/meson.build b/src/gallium/meson.build
index fc21dcf03e1..6330c7514af 100644
--- a/src/gallium/meson.build
+++ b/src/gallium/meson.build
@@ -145,7 +145,17 @@ endif
if with_gallium_st_nine
subdir('state_trackers/nine')
endif
-# TODO: clover
+if with_gallium_opencl
+ # TODO: this isn't really clover specific, but ATM clover is the only
+ # consumer
+ subdir('targets/pipe-loader')
+
+ if meson.version().version_compare('< 0.44.0')
+ error('OpenCL requires meson 0.44.0 or greater.')
+ endif
+ subdir('state_trackers/clover')
+ subdir('targets/opencl')
+endif
if with_dri
subdir('state_trackers/dri')
subdir('targets/dri')