aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/frontends/hgl/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/frontends/hgl/meson.build')
-rw-r--r--src/gallium/frontends/hgl/meson.build41
1 files changed, 41 insertions, 0 deletions
diff --git a/src/gallium/frontends/hgl/meson.build b/src/gallium/frontends/hgl/meson.build
new file mode 100644
index 00000000000..3c5870fe101
--- /dev/null
+++ b/src/gallium/frontends/hgl/meson.build
@@ -0,0 +1,41 @@
+# Copyright © 2017 Dylan Baker
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+files_libsthgl = files(
+ 'bitmap_wrapper.cpp',
+ 'bitmap_wrapper.h',
+ 'hgl_context.h',
+ 'hgl.c',
+)
+
+libsthgl_c_args = []
+if with_gallium_softpipe
+ libsthgl_c_args += '-DGALLIUM_SOFTPIPE'
+endif
+
+libsthgl = static_library(
+ 'sthgl',
+ files_libsthgl,
+ include_directories : [
+ inc_include, inc_haikugl, inc_util, inc_mesa, inc_mapi, inc_src,
+ inc_gallium, inc_gallium_aux
+ ],
+ c_args : [c_vis_args, libsthgl_c_args],
+)