summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/trace/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/drivers/trace/meson.build')
-rw-r--r--src/gallium/drivers/trace/meson.build29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/gallium/drivers/trace/meson.build b/src/gallium/drivers/trace/meson.build
new file mode 100644
index 00000000000..4fc5d8ba0f6
--- /dev/null
+++ b/src/gallium/drivers/trace/meson.build
@@ -0,0 +1,29 @@
+# Copyright © 2017 Dylan Baker
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+libtrace = static_library(
+ 'trace',
+ files('tr_context.c', 'tr_context.h', 'tr_dump.c', 'tr_dump_defines.h',
+ 'tr_dump.h', 'tr_dump_state.c', 'tr_dump_state.h', 'tr_public.h',
+ 'tr_screen.c', 'tr_screen.h', 'tr_texture.c', 'tr_texture.h'),
+ c_args : [c_msvc_compat_args, c_vis_args],
+ include_directories : [inc_gallium, inc_gallium_aux, inc_include, inc_src],
+ build_by_default : false,
+)